Blocker when integrating zoom in our webapp

I got one blocker in integrating zoom in our webapp. I referred Zoom integration · Weavy Docs for integration and completed every step. I set up my weavy instance in azure and is up and running.
The final app settings is updated in the azure config.
I tried like :
Go to the Weavy Messenger, https://{your-weavy-url}/messenger and select or create a new conversation
And I got successfully authenticated with zoom and open the weavy messenger but when I sign in with a new conversation and start zoom, Its showing like invalid redirect url.

1 Like

Guys I tried with local instance also and got the same error in local also like invalid redirect url.

1 Like

Can you attach a screenshot showing the error message/page? Sounds like you havn’t configured the correct url on the Zoom App.

Hi @magnus , The screenshot is attached here with.

@magnus ,
I gave the redirect oauth url as mentioned in the weavy docs as:
1. On the App Credentials page, enter the Redirect URL for OAuth. This is the url that Zoom will redirect to when the user is authenticated. The url should be https://{your-weavy-url}/meetings/zoom/auth and replaced with my azure weavy instance url.

It could be that Zoom requires you to add the domain to the “Oauth allow list” section below the “App Credential” section. Try to enter your domain there as and replace with yours of course.
You could also try to just add the domain as “Redirect URL for OAuth” in the same format as above. You can even specify it in the format to allow for any subdomain.

There is clearly something with the Oauth Redirect URL that Zoom complains about.

@magnus ,
I tried all that way. I already updated the o auth list with my domain.
also tried with other redirect URL as well. When i paste my weavyinstance url its redirects to weavy instance starting page.
Most confusing part is that whenever I try zoom install its giving an auth successfull page and after redirect to messenger and there when i click the zoom it’s giving like invalid redirect url.

Ok, try removing the /meetings/zoom/auth part from the “Redirect URL for OAuth” url and only use the domain,

And regarding the Install app from Zoom page, that won’t work. The authentication flow must be initiated from the Weavy Messenger. It’s not an “installable” app in that way.

@magnus ,
Tried that still having the same issue. invalid redirect url when clicking zoom in messenger.

hi @magnus ,

I tried using an incognito tab now. I login with my credientials and now in messenger(zoom meeting) signin is changed to signout, I think its authenticated but i didn’t redirect to any zoom meeting page.

Thank you for the help guys. Its working fine.
@magnus @Kris @Kris

1 Like

Great. You know that when you have added a Zoom Mereing in the Messenger, you need to send the message in order for the zoom meeting card to be added to the conversation.

1 Like

Cool. Thanks for the words @magnus .